魔趣论坛

 找回密码
 注册账号
通过您的新浪微博帐号登录
QQ登录
查看: 6199|回复: 7

[机油问答] ???ubuntu????????????? ???????

[复制链接]

该用户从未签到

升级   18%

发表于 2013-7-25 02:17:52 | 显示全部楼层 |阅读模式
ubuntu 12.04 LTS     wubi安装


安装完JDK之后继续安装依赖项时出现问题,
$ sudo apt-get install git-core gnupg flex bison gperf build-essential \
  zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
  libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \
  libgl1-mesa-dev g++-multilib mingw32 openjdk-6-jdk tofrodos \
  python-markdown libxml2-utils xsltproc zlib1g-dev:i386





下列软件包有未满足的依赖关系:
g++-multilib : 依赖: gcc-multilib (>= 4:4.6.3-1ubuntu5) 但是它将不会被安装
                依赖: g++-4.6-multilib (>= 4.6.3-1~) 但是它将不会被安装
libgl1-mesa-dev : 依赖: mesa-common-dev (= 8.0.4-0ubuntu0.6) 或
                           mesa-common-dev-lts-quantal 但是它将不会被安装 或
                           mesa-common-dev-lts-raring 但无法安装它
libgl1-mesa-glx:i386 : 依赖: libdrm2:i386 (>= 2.3.1) 但是它将不会被安装
                        推荐: libgl1-mesa-dri:i386 (>= 7.2)
libncurses5-dev:i386 : 依赖: libc-dev:i386
zlib1g-dev:i386 : 依赖: libc6-dev:i386 但是它将不会被安装 或
                           libc-dev:i386
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。









不知道怎么解决,不知各位都是怎么解决这个问题的
回复

使用道具 举报

该用户从未签到

升级   18%

发表于 2013-7-25 02:18:38 | 显示全部楼层
@martincz
回复 支持 反对

使用道具 举报

  • TA的每日心情
    奋斗
    2017-6-28 20:44
  • 签到天数: 1303 天

    连续签到: 1 天

    [LV.10]以坛为家III

    发表于 2013-7-25 03:25:57 | 显示全部楼层
    看看android开发页面,12.04需要安装的东西不太一样。
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    升级   18.22%

    发表于 2013-7-30 08:38:50 | 显示全部楼层
    我连普通的软件都不知道怎么装,尼玛,这Linux太坑了
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2013-8-1 19:09
  • 签到天数: 1 天

    连续签到: 1 天

    [LV.1]初来乍到

    升级   4%

    发表于 2013-8-1 19:28:13 | 显示全部楼层
    ubuntu 13.04 failed too

    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    慵懒
    2013-4-24 12:27
  • 签到天数: 56 天

    连续签到: 1 天

    [LV.5]常住居民I

    升级   3.09%

    发表于 2013-8-2 09:09:26 来自移动版 | 显示全部楼层
    骗、骗、骗子 发表于 2013-7-30 08:38
    我连普通的软件都不知道怎么装,尼玛,这Linux太坑了

    我反而觉得linux的包管理系统比windows要自己找方便多了。
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    升级   18.22%

    发表于 2013-8-2 20:11:00 | 显示全部楼层
    deathscythe 发表于 2013-8-2 09:09
    我反而觉得linux的包管理系统比windows要自己找方便多了。

    尼玛,我怎么都装不上,不懂怎么搞的
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2013-9-7 20:33
  • 签到天数: 1 天

    连续签到: 1 天

    [LV.1]初来乍到

    升级   8.64%

    发表于 2013-8-9 17:18:14 | 显示全部楼层
    顶一下lz,不知道能不能给点鲜花啥的?{:4_142:}{:4_142:}
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 注册账号  

    本版积分规则

    手机版|魔趣论坛 |

    我们旨在提供一个良好的手机玩家技术交流、资源分享社区,如果有涉及版权的资源,请联系管理员并提供相应的版权证明,我们会进行相应处理。

    GMT+8, 2017-11-19 03:15 , Processed in 0.083583 second(s), 40 queries , Gzip On, Redis On.

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表